PayPal object–invalid security certificate error

When trying to access PayPal in Firefox browser, if you get error such as www.paypalobkects.com:443 uses an invalid security certificate, error code;sec_error-expired-certificate then check the date time set on your PC

image

This might occur if you have changed your PC date to any past date. The resolution is to change the date to current date and time.

In Category: Technical

Ravi Shankar

A Software developer and blogger who is always looking to provide technical help to the wider community.

Show 0 Comments
No comments yet. Be the first.

Leave a Comment

Get your free copies of the following tech guides by joining the Digital Answers mailing list.